WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#23241 closed enhancement (duplicate)

Add a filter hook to the "Insert/edit link > link to existing content" query

Reported by: lumpysimon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Administration Keywords: has-patch needs-testing
Focuses: Cc:
PR Number:

Description

There's currently no way to filter the results of the query performed when using the "Insert/edit link > Link to existing content" option in the modal window.

In my case, I need to restrict the post types shown in the results based on the user's role. You might also want to change the order/orderby parameters, etc.

Attachments (1)

class-wp-editor.php.patch (406 bytes) - added by lumpysimon 7 years ago.

Download all attachments as: .zip

Change History (4)

#1 @lumpysimon
7 years ago

  • Cc piemanek@… added
  • Keywords has-patch needs-testing added

#2 @johnbillion
7 years ago

  • Cc johnbillion added

#3 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18042.

Note: See TracTickets for help on using tickets.