WordPress.org

Make WordPress Core

#23274 closed feature request (duplicate)

Use image crop on specific custom size

Reported by: helgatheviking Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

I think you should be able to crop your custom image sizes from the media editor. Right now you you only have 3 choices, "thumbnail", "all except thumbnail" which I think is pretty limiting. If you added a hook in there plugin devs could add custom sizes, or perhaps even core could have a foreach loop for all the size. The handling of the individual resize should then be pretty similar to what happens when only the "thumbnail" is selected for resize.

Also, "All image sizes" seem to also include the full size, original image. I don't know if this is intentional.

In /wp-admin/includes/image-edit.php

	<p id="imgedit-save-target-<?php echo $post_id; ?>">
		<strong><?php _e('Apply changes to:'); ?></strong><br />

		<label class="imgedit-label">
		<input type="radio" name="imgedit-target-<?php echo $post_id; ?>" value="all" checked="checked" />
		<?php _e('All image sizes'); ?></label>

		<label class="imgedit-label">
		<input type="radio" name="imgedit-target-<?php echo $post_id; ?>" value="thumbnail" />
		<?php _e('Thumbnail'); ?></label>

		<label class="imgedit-label">
		<input type="radio" name="imgedit-target-<?php echo $post_id; ?>" value="nothumb" />
		<?php _e('All sizes except thumbnail'); ?></label>

	</p>

Apply changes to:

Change History (7)

comment:1 markoheijnen15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19889.

comment:2 helgatheviking15 months ago

I don't think this is a duplicate. #19889 is saying that the cropping isn't being applied to the custom sizes. I am suggesting the ability to "choose" which custom size you'd like to crop. They are certainly related however.

In a perfect world, my image edit screen would look like:

  • Crop thumbnail only
  • Crop portfolio only
  • Crop large only
  • Crop all

Maybe the sizes would even be checkboxes instead of radio buttons so you could crop more than one, but not all simultaneously.

Maybe a better suggestion would be:

  • Crop all
  • Crop sizes

# thumbnail
# medium
# large
# portfolio
# full

Please forgive my crude markup... * is meant to be a radio button and # is meant to be a checkbox.

comment:3 helen15 months ago

I imagine that it would all get fixed together, so in that sense, it is a duplicate. The UI can't be added if it doesn't get applied.

comment:4 helgatheviking15 months ago

That's true. I'm just hoping you'll add the feature in while you are fixing the bug. You did an awesome job overhauling the media editor already, btw!

comment:5 WraithKenny15 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Aside from the bug on #19889 blocking the enhancement on this ticket, I don't think it's a duplicate. The comments on that ticket say that this feature request isn't in scope of that ticket (#19889) and asked for a new ticket for the enhancement...

comment:6 WraithKenny15 months ago

Unless this feature is already actually in, and I didn't notice, and #19889 is hiding it. In which this ticket is a dup bug. In that case my bad.

comment:7 SergeyBiryukov15 months ago

  • Component changed from General to Media
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #22990.

Note: See TracTickets for help on using tickets.