Make WordPress Core

Opened 3 years ago

Closed 17 months ago

Last modified 14 months ago

#23281 closed enhancement (duplicate)

Enhancement for comment_form(); allow styling the submit button

Reported by: Danielx64 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Comments Keywords:
Focuses: template Cc:


Hi there,

I'm looking at adding a feature where we can define the class for the submit button. I'm happy to create a patch for this if required. The reason for this is because right now we can change say the email field so much but we get little to no concrol over the submit button.

I'm looking at

A: Convert the entire submit button into somehing like how the text areas are done (author and email) then we get full control over the styling and other things related or;

B Add something like class_submit so that we can set the style of the submit button.

Kind regards,

Daniel Fenn

Attachments (1)

comment_form.diff (436 bytes) - added by Danielx64 3 years ago.
Just make a patch for add class feature

Download all attachments as: .zip

Change History (8)

comment:1 @Danielx643 years ago

  • Summary changed from Enhancement for comment_form(); to Enhancement for comment_form(); allow styling the submit button

comment:2 @Danielx643 years ago

  • Keywords has-patch added

Not sure if I make the patch right

@Danielx643 years ago

Just make a patch for add class feature

comment:4 in reply to: ↑ 3 @Danielx643 years ago

Replying to SergeyBiryukov:

No, comment_form.diff isn't a correct patch.

Please take a look at http://make.wordpress.org/core/handbook/submitting-a-patch/.

Do you know how I can do this without svn? I do alot of my dev stuff on a server that never reach the internet. This time I used the diff tool that was in centos :'(

comment:5 @nacin20 months ago

  • Component changed from Template to Comments
  • Focuses template added

comment:6 @obenland17 months ago

  • Keywords has-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

There are plenty of possibilities to style the submit button of the comment form. I don't think we need to add a class in order to do that.

Developers can use the (customizable) id attribute, or target the button through a selector like .comment-form [type="submit"], just to name a few.

Feel free to reopen if there's a use case for it beyond what has been discussed so far.

comment:7 @SergeyBiryukov14 months ago

  • Resolution changed from wontfix to duplicate

Duplicate of #20446.

Note: See TracTickets for help on using tickets.