WordPress.org

Make WordPress Core

Changes between Version 1 and Version 2 of Ticket #23285, comment 8


Ignore:
Timestamp:
01/25/13 04:34:20 (15 months ago)
Author:
auniquename
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #23285, comment 8

    v1 v2  
    99I just don't see any reason why not include some way to deal with js lib version dependencies. Not doing so causes more problems than doing so as I see it. 
    1010 
    11 Also, the release cycle is frequent enough to make all this a lot of work, too much? Even just thinking about how to write a plugin that supports multiple versions of WordPress and multiple versions of js libs is giving me braincramps. I cannot count on users updating their sites to the latest versions, so if I want my plugin to work on the most sites possible I need to write it to account for a whole quarterly history of jQuery revisions back a few years at least. Why put people through that? Overall man hours expended to implement a AMD style loader in WordPress would be considerably less. Set it and forget it I say. 
     11Also, the release cycle is frequent enough to make all this a lot of work, too much? Even just thinking about how to write a plugin that supports multiple versions of WordPress and multiple versions of js libs is giving me braincramps. I cannot count on users updating their sites to the latest versions, so if I want my plugin to work on the most sites possible I need to write it to account for a whole quarterly history of jQuery revisions back a few years at least. Why put people through that? Overall man hours expended to implement an AMD style loader or some kind of mechanism to deal with multiple versions of js libs in WordPress would be considerably less. Set it and forget it I say.