WordPress.org

Make WordPress Core

#23296 closed defect (bug) (worksforme)

3.6 - Edit Post, Invalid implode after Core-Update

Reported by: hovida Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Warnings/Notices Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Error: implode(): Invalid arguments passed

The implode function have invalid Arguments.

URL: /wp-admin/edit.php

HTTP referrer: http://adrean-test.eatserver.nl/wp-admin/update-core.php

FIX (wp-includes/compat.php - Line 32):

return ($chars  ? implode( '', $chars ) : array());

Stacktrace:

in implode called at /www/htdocs-test/wp-includes/compat.php (32)
in _mb_substr called at /www/htdocs-test/wp-includes/compat.php (18)
in mb_substr called at /www/htdocs-test/wp-includes/formatting.php (3096)
in wp_html_excerpt called at /www/htdocs-test/wp-includes/admin-bar.php (230)
in wp_admin_bar_site_menu called at ? (?)
in call_user_func_array called at /www/htdocs-test/wp-includes/plugin.php (487)
in do_action_ref_array called at /www/htdocs-test/wp-includes/admin-bar.php (58)
in wp_admin_bar_render called at ? (?)
in call_user_func_array called at /www/htdocs-test/wp-includes/plugin.php (406)
in do_action called at /www/htdocs-test/wp-admin/admin-header.php (113)
in require_once called at /www/htdocs-test/wp-admin/edit.php (220)

Change History (5)

comment:1 SergeyBiryukov15 months ago

  • Component changed from Upgrade/Install to Warnings/Notices
  • Description modified (diff)
  • Keywords reporter-feedback added; needs-patch removed

I've disabled the mbstring extension on my install to force the compat version to run instead, but still could not reproduce the issue.

mb_substr() is called via wp_html_excerpt() for the blog name in Toolbar. If the blog name is empty, the host name is used instead:
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-includes/admin-bar.php#L219

What's the value of $blogname in your case?

comment:2 SergeyBiryukov15 months ago

Can you reproduce the issue on a clean install (with Twenty Twelve or Twenty Eleven theme activated and all plugins disabled)?

comment:3 hovida15 months ago

That was an clean installation. No Plugins enabled, problem are directrly after Core update.

comment:4 SergeyBiryukov15 months ago

From which version?

comment:5 SergeyBiryukov10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.