Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#23297 closed defect (bug) (duplicate)

Translated $hook_suffix

Reported by: brasofilo's profile brasofilo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Depending on WPLANG, I'm getting a different $hook_suffix / $current_screen->base

I traced the origin to the function get_plugin_page_hookname() in /wp-admin/includes/plugin.php, but can't see a solution.

Experiencing this using the plugin Advanced Custom Fields. I'm trying to hook in the plugin page and just discovered this issue, one would expect this kind of slug not to be translated.

(attachments, $current_screen object with default WPLANG and defined as pt_BR)

Only found refence to this in Ticket: #8246

Attachments (1)

current_screen-WPLANG.png (47.4 KB) - added by brasofilo 11 years ago.

Download all attachments as: .zip

Change History (2)

#1 @SergeyBiryukov
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18857.

Note: See TracTickets for help on using tickets.