WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#23320 closed defect (bug) (fixed)

"Download failed. Not Found" when installing my plugin

Reported by: metaphorcreations Owned by:
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:
PR Number:

Description

I am receiving a "Download failed. Not Found" about 50% of the time when trying to install a fresh version of DItty News Ticker http://wordpress.org/extend/plugins/ditty-news-ticker/ through the Plugin installer.

I have had one user make not of this on the plugin's support forums, but I'm sure there are many more who are running into it and just moving on.

Change History (10)

#1 @metaphorcreations
7 years ago

  • Cc metaphorcreations added

#2 @SergeyBiryukov
7 years ago

  • Component changed from Plugins to WordPress.org site
  • Milestone changed from Awaiting Review to WordPress.org
  • Version trunk deleted

Tested on two installs (local and remote), could not reproduce. Sounds like a network issue or a temporary issue on WP.org rather than something that can be fixed in core.

#3 @rmccue
7 years ago

  • Keywords dev-feedback removed
  • Milestone WordPress.org deleted
  • Resolution set to invalid
  • Status changed from new to closed

Likewise. Closing as invalid, if you can reproduce it constantly, reopen this ticket.

#4 @dd32
7 years ago

  • Milestone set to WordPress.org
  • Resolution invalid deleted
  • Severity changed from critical to normal
  • Status changed from closed to reopened

I can duplicate with that plugin, takes a few requests to trigger it.

dd32:~/public_html$ curl -I http://downloads.wordpress.org/plugin/ditty-news-ticker.zip
HTTP/1.1 200 OK
Server: nginx
Date: Wed, 30 Jan 2013 04:57:50 GMT
Content-Type: application/octet-stream
Content-Length: 74496
Connection: close
Pragma: no-cache
Cache-control: private
Content-Description: File Transfer
Content-Disposition: attachment; filename=ditty-news-ticker.zip
X-nc: MISS luv 138

dd32:~/public_html$ curl -I http://downloads.wordpress.org/plugin/ditty-news-ticker.zip
HTTP/1.1 200 OK
Server: nginx
Date: Wed, 30 Jan 2013 04:57:51 GMT
Content-Type: application/octet-stream
Content-Length: 74496
Connection: close
Pragma: no-cache
Cache-control: private
Content-Description: File Transfer
Content-Disposition: attachment; filename=ditty-news-ticker.zip
X-nc: MISS luv 139

dd32:~/public_html$ curl -I http://downloads.wordpress.org/plugin/ditty-news-ticker.zip
HTTP/1.1 404 Not Found
Server: nginx
Date: Wed, 30 Jan 2013 04:57:52 GMT
Content-Type: text/html; charset=UTF-8
Connection: close
Vary: Accept-Encoding

#5 @metaphorcreations
7 years ago

  • Component changed from WordPress.org site to Plugins

I recently had a "Download failed. Not Found" when just to download the plugin from wordpress.org. I am not sure what the issue is, but it does seem to happen about 25% of the time for me.

I don't know if it has anything to do with an subversion error on my part.. I'm very new to it. But, since it it downloads fine a lot of the time and the plugin works as it should when installed, I'm assuming I didn't mess anything up.

#6 @metaphorcreations
7 years ago

  • Component changed from Plugins to WordPress.org site

Whoops, probably should leave it as WordPress.org

#7 @metaphorcreations
7 years ago

I just attempted to install my plugin again and it failed 3 times in a row. I'm using Chrome Version 24.0.1312.57 on a Macbook Pro running OSX 10.8.2

I really need someone to look at this again. I have never had this issue installing other plugins so I do not believe this is a network issue. I'm sure I can't be the only one having this issue (frequently) when trying to install my plugin.

Thanks.

#8 @metaphorcreations
7 years ago

I changed my stable tag from /trunk/ to my latest versio (1.0.3) and it seems to be working better that way.

#9 @nacin
7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Okay, we've tracked this one down. One of the web nodes is having issues. It's been removed from production.

#10 @metaphorcreations
7 years ago

Great! Thank you!

Note: See TracTickets for help on using tickets.