WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#23324 closed defect (bug) (duplicate)

TinyMCE strips paragraphs/new lines when used in table.

Reported by: eskapism Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Formatting Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

When writing text inside a table TinyMCE strips paragraphs when switching between the Visual tab and the Text tab. This also happens on save, so you actually don't have to use the visual/text-tabs.

I only seems to do it with paragraphs, not with br/ctrl-enter-lines.

Consider this HTML:

<table border="0">
<tbody>
<tr align="left" valign="top">
<td>New line 3
New line 4
New line 5

&nbsp;

&nbsp;

&nbsp;

New paragraph</td>
</tr>
</tbody>
</table>

If you click visual tab and then text tab a couple of times (like 4 or 5)

You end up with this:

<table border="0">
<tbody>
<tr align="left" valign="top">
<td>New line 3
New line 4
New line 5New paragraph</td>
</tr>
</tbody>
</table>

May be a duplicate of #6485 and if it is I don't quite understand why it is/was a wont-fix.

Tested in Chrome 25.0.1364.45 beta and FireFox 18.0.1 and WordPress 3.5.1 and WordPress 3.6-alpha-23288.

Attachments (1)

tinymce-paragraph-bug.png (24.1 KB) - added by eskapism 3 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 @SergeyBiryukov3 years ago

  • Component changed from General to Formatting
  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20943.

Note: See TracTickets for help on using tickets.