WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#23344 closed defect (bug) (duplicate)

'preview' query var is not removed from post URL if a post has been published

Reported by: amit Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Canonical Keywords:
Focuses: Cc:

Description

If a post has been published, it can be loaded via a URL containing 'p' & 'preview' query vars and a canonical redirect is not done to post permalink which results in two URLs with same content and causes a duplicate content issue with search engines like Google.

For example:

http://example.dev/?p=731

would redirect to

http://example.dev/post-slug/

but

http://example.dev/?p=731&preview=true

does not redirect anywhere & remains same. So if this URL is somehow indexed by search engines they would have two URLs with same content:

http://example.dev/post-slug/
http://example.dev/?p=731&preview=true

and thus the duplicate content penalization.

Attachments (1)

published-post-preview-canonical-redirect.patch (1.6 KB) - added by amit 8 years ago.
Patch for Ticket #23344

Download all attachments as: .zip

Change History (3)

#1 @mintindeed
8 years ago

  • Cc gabriel.koen@… added

#2 @helen
8 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20496.

Note: See TracTickets for help on using tickets.