WordPress.org

Make WordPress Core

#23359 closed defect (bug) (duplicate)

Remove format button removes more then format

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Remove format button will remove color styling, strip the strong and em tags, but will leave the del tag alone.

As far as my understanding of HTML5 goes, strong and em are semantic elements and not styling elements, therefor should not be stripped. OTOH del is not stripped so at least the behaviour is not very consistent.

A major problem is that something like the removal works inside a del tag:

<del>this is <strong>Important</strong></del>


will become

<del>this is Important</del>


changing the importance attributed to the word "Important" before the deletion

Change History (1)

comment:1 SergeyBiryukov15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22799.

Note: See TracTickets for help on using tickets.