Make WordPress Core

Opened 11 years ago

Closed 10 years ago

#23364 closed defect (bug) (worksforme)

Unstable sorting with jQuery UI 1.9.1 and above

Reported by: marventus's profile Marventus Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: External Libraries Keywords:
Focuses: Cc:

Description

There seems to be an issue with jQuery UI (sortable) 1.9.1 and above that affects (rather severely) sorting of elements inside sortable source and target containers. I haven't seen this affect core, but since WP has been shipping with one of the affected versions (1.9.2) since 3.5, I'm worried about potential repercussions on WP theemes, plugins or projects relying on this script. For instance, Ultimate Tinymce, by Josh Lobe and myself (recently), has been affected by this.
Here is a testing platform I created on my server about the problem. Choosing any version of UI newer than 1.9.0 will result in said behavior.
Here is the ticket I submitted to jquery UI Trac and here the Commits to their github project.
Finally, as recommended by Andrew Nacin on the wp-forums list, here is a JSFiddle that reproduces the problem.
I am not really sure what to do about this, but I thought I should leave it on record just in case.
Thanks!

Change History (3)

#1 @nacin
11 years ago

As this is purely a jQuery UI bug that does not affect core functionality, a single ticket upstream is sufficient for this. I will see to it that it gets looked at. It's the folks upstream that will want a JSFiddle, so thanks for that.

#2 @jeremyfelt
10 years ago

  • Keywords close added; 2nd-opinion removed

Looks like this landed in jQuery UI 1.10.2, which was brought into core as of [23892].

#3 @ocean90
10 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.