WordPress.org

Make WordPress Core

#23370 closed enhancement (fixed)

Update to jQuery UI 1.10.*

Reported by: ocean90 Owned by: nacin
Milestone: 3.6 Priority: normal
Severity: normal Version:
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Attachments (7)

23370.patch (472.7 KB) - added by ocean90 15 months ago.
23370.2.patch (435.3 KB) - added by ocean90 14 months ago.
jQuery UI 1.10.1
23370.3.patch (18.4 KB) - added by ocean90 14 months ago.
23370.4.patch (18.4 KB) - added by ocean90 14 months ago.
refresh of .3
23370.5.patch (472.7 KB) - added by ocean90 13 months ago.
UI 1.10.2
23370.5.2.patch (472.7 KB) - added by ocean90 13 months ago.
23370.6.patch (453.2 KB) - added by ocean90 12 months ago.
jQuery UI 1.10.3

Change History (28)

ocean9015 months ago

comment:1 follow-up: ocean9015 months ago

Because of the Dialog API Redesign (Upgrade Guide) there is an issue with the edit/insert link dialog, see http://cl.ly/Md0u

Last edited 15 months ago by ocean90 (previous) (diff)

comment:2 nacin14 months ago

In 23423:

jQuery UI 1.10.0.

Some lingering issues with the edit/insert link dialog.

props ocean90.
see #23370.

comment:3 in reply to: ↑ 1 ocean9014 months ago

  • Keywords needs-patch added; has-patch needs-testing removed

Replying to ocean90:

Because of the Dialog API Redesign (Upgrade Guide) there is an issue with the edit/insert link dialog, see http://cl.ly/Md0u

ocean9014 months ago

jQuery UI 1.10.1

comment:4 ocean9014 months ago

  • Keywords has-patch added; needs-patch removed
  • Summary changed from Update to jQuery UI 1.10.0 to Update to jQuery UI 1.10.*

comment:5 nacin14 months ago

In 23442:

jQuery UI 1.10.1.

props ocean90. see #23370.

ocean9014 months ago

comment:6 ocean9014 months ago

23370.3.patch:

  • Syncs the jQuery UI CSS styles with the current one
  • Hardcodes the old z-index values, since the zIndex attribute is gone
  • Fixes the close button

Patch tested in Chrome, Opera, Safari Firefox, IE 7-10. RTL tested too.

comment:7 ocean9014 months ago

Another issue:

Open DFW and switch to text mode. Add a link. Link will be added but you get an error too:

Uncaught TypeError: Cannot call method '_focusTabbable' of undefined j
query.ui.dialog.min.js:5
(anonymous function) jquery.ui.dialog.min.js:5
jQuery.event.dispatch jquery.js:3074
elemData.handle jquery.js:2750
jQuery.event.trigger jquery.js:2986
jQuery.event.trigger jquery-migrate.js:468
jQuery.event.simulate jquery.js:3301
handler jquery.js:3552
wpLink.htmlUpdate wplink.js:212
wpLink.update wplink.js:158
(anonymous function) wplink.js:35
jQuery.event.dispatch jquery.js:3074
elemData.handle

Related: http://bugs.jqueryui.com/ticket/9000

ocean9014 months ago

refresh of .3

comment:8 ocean9014 months ago

  • Keywords commit added

comment:9 nacin14 months ago

Is there an upstream regression fixed by 23370.4.patch?

Is the issue in comment 7 still an issue in 1.10.1? If so, do we need to report something upstream?

comment:10 ocean9014 months ago

Is there an upstream regression fixed by 23370.4.patch​?

Yesno. They removed support for a zindex property.

Is the issue in comment 7 still an issue in 1.10.1?

Yes.

If so, do we need to report something upstream?

No. http://bugs.jqueryui.com/ticket/9097

comment:11 nacin14 months ago

Also, here is where zindex was removed. Not a major issue, they just no longer wanted to juggle z-index and would prefer that it is left to CSS. http://bugs.jqueryui.com/ticket/8729

comment:12 nacin14 months ago

In 23515:

Fix internal linking dialog conflicts with jQuery UI 1.10.x. Syncs jQuery UI CSS styles.

Remaining issue will be fixed in 1.10.2 final.
props ocean90.
see #23370.

comment:13 ocean9014 months ago

  • Keywords needs-patch added; has-patch commit removed

So, waiting for 1.10.2.

ocean9013 months ago

UI 1.10.2

ocean9013 months ago

comment:15 ocean9013 months ago

  • Keywords commit added

comment:16 nacin13 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 23892:

jQuery UI 1.10.2.

props ocean90. fixes #23370.

comment:17 follow-up: programmin12 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is causing a z-index conflict in /wp-includes/css/jquery-ui-dialog.css:

.ui-widget-overlay {
 z-index: 300001;

is over

.ui-front {
 z-index: 100;

A new dialog has its shadow in front of it, you can't click 'close'. For example, try this on a wp-admin page:

var msg = '<div>hello</div>';
jQuery(msg).dialog({ draggable: false, resizable: false, modal: true });

The close button and the form are behind the overlay.

Last edited 12 months ago by SergeyBiryukov (previous) (diff)

comment:18 in reply to: ↑ 17 adamsilverstein12 months ago

i checked into the issue you reported on the dialog not loading correctly. your code indeed shows the dialog behind the overlay, oops! i figured out you need do do something slightly different, nothing is wrong with the CSS!

not sure if this is documented anywhere, but it looks like you need to add the wp-dialog class to your dialogs to get them to show up properly in the admin interface, try this update of your example to see what happens, you should see the modal:

var msg = '<div>hello this is a test</div>';
jQuery(msg).dialog({ draggable: false, resizable: false, modal: true, dialogClass: 'wp-dialog' });

Replying to programmin:

This is causing a z-index conflict in /wp-includes/css/jquery-ui-dialog.css:

.ui-widget-overlay {
 z-index: 300001;

is over

.ui-front {
 z-index: 100;

A new dialog has its shadow in front of it, you can't click 'close'. For example, try this on a wp-admin page:

var msg = '<div>hello</div>';
jQuery(msg).dialog({ draggable: false, resizable: false, modal: true });

The close button and the form are behind the overlay.

comment:19 adamsilverstein12 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

ocean9012 months ago

jQuery UI 1.10.3

comment:20 ocean9012 months ago

  • Keywords commit removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:21 ocean9012 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 24204:

jQuery UI 1.10.3. fixes #23370.

Note: See TracTickets for help on using tickets.