WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#23375 closed defect (bug) (duplicate)

Bug in <p></p>

Reported by: Looimaster Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

We all know that WordPress adds unwanted <p> and </p> everywhere which is alone a frustrating bug for me.

But if you do something like this manually:
<p>test <samp>test2</samp> test3</p>

Then it will be displayed like:
<p>test <samp>test2</samp></p><p>test3</p>

But this...:
<p>test <b>test2</b> test3</p>

...will be displayed like:
<p>test <b>test2</b> test3</p>

It performs wrong match of </p> with </samp>.

Change History (1)

#1 @ocean90
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 3.5.1 deleted

Duplicate of #18807.

Note: See TracTickets for help on using tickets.