WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 3 months ago

Last modified 3 months ago

#23382 closed defect (bug) (worksforme)

WordPress admin panel lags

Reported by: Looimaster Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: dev-feedback
Focuses: Cc:

Description

I'm using Windows 7, brand-new laptop with i7 processor, 8GB RAM and 1080p resolution.

I have created a post with 15 1920x1080 images in it and a lot of content (25000 characters). Results:

CHROME & CHROME CANARY

It's far from being usable at all. It lags that much that cursor doesn't even change from "default" to "pointer" when I hover over "Publish" button. Even switching to WordPress Admin Panel tab takes 5 seconds. Textareas are not resizable because lags prevent my mouse cursor from doing anything. Actually, entire Admin Panel lags, all these Drag&Drop widgets etc.

FIREFOX

A bit better than Chrome, everything lags but at least I can resize textareas and after 10 seconds it becomes usable. Nonetheless, it's not as smooth as other websites.

IE10

Excellent. Not even a single slowdown!

SAFARI

Very close to IE10.

I think that WordPress Admin Panel is stuffed with heavy Javascript. Maybe it's worth taking a look at that. The module that seems to be the heaviest is TinyMCE - when this appears then lags appear as well. Chrome works fine everywhere except WP Admin Panel.

Good luck guys and thank you for your hard work during WordPress development :) My complaints are here only to make it better. I can live with these lags (since I can do it in IE10) but those are just my thoughts (many people use Chrome).

Attachments (1)

Screen Shot 2013-05-15 at 12.30.13 PM.png (333.9 KB) - added by csixty4 11 months ago.
Heap snapshot showing Uploader retaining a detached DOM tree

Download all attachments as: .zip

Change History (9)

comment:1 csixty411 months ago

Can't reproduce

i5 @ 1.7GHz
4GB RAM
MacOS 10.8.3
Chrome 26.0.1410.65
WordPress 3.6 trunk (05/15/2013)
25,000 characters (3755 words) of Lorem Ipsum
15 full-size 1920x1080 images

Will keep investigating...

comment:2 csixty411 months ago

Performance is also good in Firefox 17.0.1 (all else the same)

Possibly a plugin issue?

comment:3 Looimaster11 months ago

It may be related to Chrome and Firefox - maybe they don't free memory at this moment or they are not optimized. This doesn't happen every single time. When I open a new tab in either of these browsers it works just like a normal website. Problems arise when you keep using that every single day for 5 to 10 hours - at least a few times daily it stops being usable.

WordPress' admin panel isn't an exception - I notice the same slowdowns, lags etc. in websites that intensively use Javascript and CSS3 animations.

It's not easy to be reproduced but I can notice a difference in performance between simple HTML document and a page full of Javascript and AJAX. CSS3 gradients and all such stuff makes it heavy. I think that this ticket can be set as "invalid" but it's something to keep in mind and pay attention to. And if you ever notice that it's not smooth I think that it's worth investigating.

Version 1, edited 11 months ago by Looimaster (previous) (next) (diff)

comment:4 csixty411 months ago

I'm seeing some potentially leaked memory related to the Uploader. Might be a red herring. I'll see if I can't set up some sort of Selenium script this weekend to run through a bunch of stuff (including opening & closing the uploader) for a couple hours and get some profiling data.

csixty411 months ago

Heap snapshot showing Uploader retaining a detached DOM tree

comment:5 csixty411 months ago

  • Type changed from enhancement to defect (bug)

Just a note to whoever on the core team might be reading this. A recent version of Backbone introduced the listenTo method. Switching the .on methods in wp-includes/js/media-views.js to use .listenTo didn't do anything to prevent these detached DOM trees from hanging around, it might be good to update the code & take advantage of this new paradigm at some point.

comment:6 c3mdigital8 months ago

  • Keywords dev-feedback added

comment:7 azaozz3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Another cause might be that the browsers didn't use the video card properly. Graphic and graphic effects heavy web pages (lots of gradients and box-shadows) are known to bring some PCs to a crawl while other, less powerful PCs work pretty well. That was traced to the browser not using "hardware acceleration". As far as I know this is fixed now.

Feel free to reopen if this is still a problem.

comment:8 nacin3 months ago

For performance problems, it would also be best for tickets to reflect specific issues that can be profiled and patched. We're of course happy to fix memory leaks and general degradation. (That includes what I see here mentioned, references to both Uploader and Backbone.)

Note: See TracTickets for help on using tickets.