WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#23403 closed defect (bug) (duplicate)

Add folder support for the mu-plugins directory (similar to how /plugins works)

Reported by: aaronholbrook Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:
PR Number:

Description

Relating to this discussion, and as documented here

WordPress only looks for PHP files right inside the mu-plugins directory, and (unlike for normal plugins) not for files in subdirectories. You may want to create a proxy PHP loader file inside the mu-plugins directory:

I propose that we fashion the /mu-plugins to act in a similar fashion to the /plugins folder which looks for plugins either by themselves or in a folder with a named .php file.

Change History (4)

#1 @Otto42
7 years ago

-1. I don't see the point. Just use /plugins if you need them to behave the same way as /plugins does.

#2 @toscho
7 years ago

  • Cc info@… added

+1. Some plugins must be mu-plugins, for example when they set cookie constants. There is no reason to restrict those plugins.

#4 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14359 and #5207.

Note: See TracTickets for help on using tickets.