WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 8 months ago

#23427 closed enhancement (fixed)

Make shift-click checkbox range selection work in both directions

Reported by: sillybean Owned by: helen
Milestone: 3.7 Priority: normal
Severity: normal Version: 3.5
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

It used to be possible to select a range of checkboxes in the post list by shift-clicking (see #6541). I'm not entirely sure when this feature disappeared, but it's been a while.

Patch restores the functionality using the jQuery shiftcheckbox plugin.

Attachments (3)

shiftcheckbox.diff (4.4 KB) - added by sillybean 15 months ago.
restores ability to select consecutive checkboxes by shift-clicking
23427.patch (918 bytes) - added by c3mdigital 8 months ago.
Allows bulk checking in both directions
23427.2.patch (1015 bytes) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (17)

sillybean15 months ago

restores ability to select consecutive checkboxes by shift-clicking

comment:1 nacin15 months ago

Works for me on trunk. Selected the first checkbox and the fifth checkbox, while holding shift. Two through four were selected.

comment:2 johnbillion14 months ago

  • Keywords reporter-feedback added

Yep, works for me on Chrome Win7/OSX, Firefox Win7/OSX and IE9 Win7.

sillybean: Can you reproduce using the default theme and with all plugins disabled?

comment:3 SergeyBiryukov14 months ago

  • Component changed from General to Administration
  • Keywords ui-focus added

Works for me in Firefox 18, IE 8, and Opera 12.

comment:4 follow-up: sillybean14 months ago

The built-in method does work on posts and pages with no plugins installed. It does not work on other screens where it would be useful: the plugins list, for example, or any list tables generated by plugins.

The built-in method also breaks at the drop of a hat. Even otherwise well-behaved plugins cause weirdness, like being able to select top-down but not bottom-up.

The patch seems to be more robust than whatever's built in now, and it works on other screens.

comment:5 sillybean14 months ago

  • Keywords reporter-feedback removed

comment:6 in reply to: ↑ 4 SergeyBiryukov14 months ago

Replying to sillybean:

The built-in method does work on posts and pages with no plugins installed. It does not work on other screens where it would be useful: the plugins list, for example, or any list tables generated by plugins.

It does work for me on the Plugins screen as well as on CPT list tables. Tested in Firefox 19, Chrome 25, IE 8, Opera 12. The relevant code is in common.js:
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-admin/js/common.js#L273

comment:7 MikeHansenMe14 months ago

  • Keywords close added

This is also working for me on FF 19. Proposing close as worksforme

comment:8 sillybean9 months ago

  • Summary changed from Restore shift-click checkbox range selection to Make shift-click checkbox range selection work in both directions

I've been working on trunk all day, and the problem is still there: shift-click selection works downward, but not upward. I have no plugins installed that might interfere with the JS.

comment:9 c3mdigital8 months ago

  • Keywords needs-patch added; has-patch ui-focus close removed

c3mdigital8 months ago

Allows bulk checking in both directions

comment:10 c3mdigital8 months ago

  • Keywords has-patch added; needs-patch removed

Bulk checking both directions for any WP_List_Table generated list table.

comment:11 sillybean8 months ago

Latest patch works for me.

SergeyBiryukov8 months ago

comment:12 SergeyBiryukov8 months ago

  • Milestone changed from Awaiting Review to 3.7

23427.2.patch builds on 23427.patch without duplicating the code.

comment:13 helen8 months ago

I like 23427.2.patch and it's working nicely.

comment:14 helen8 months ago

  • Owner set to helen
  • Resolution set to fixed
  • Status changed from new to closed

In 25141:

Make shift-click checkbox range selection work in both directions. props c3mdigital, SergeyBiryukov. fixes #23427.

Note: See TracTickets for help on using tickets.