Make WordPress Core

Opened 11 years ago

Closed 3 years ago

Last modified 3 years ago

#23455 closed defect (bug) (duplicate)

Theme Customizer does not load when static Front Page is moved to Trash

Reported by: jeherve's profile jeherve Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Customize Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Go to Pages > Add New, and publish a new page
  2. Go to Appearance > Themes > Customize
  3. Under Static Front Page, set this new Page as your Front Page. Save changes
  4. Go to Pages > All Pages, and trash the page
  5. Go back to the customizer

When commenting out $this->handle_404(); in wp-includes/class-wp.php#L550, the Preview appears again, but generates quite a lot of notices.

Tested with WordPress Trunk (Version 3.6-alpha-23400)

Change History (20)

#1 follow-up: @helen
11 years ago

  • Keywords reporter-feedback added

What happens on the front when you trash the front page? Seems like the customizer is loading fine, and it's probably showing the front just as it is.

#2 in reply to: ↑ 1 @westi
11 years ago

Replying to helen:

What happens on the front when you trash the front page? Seems like the customizer is loading fine, and it's probably showing the front just as it is.

What happens in my testing is the request for all the customiser data gets the 404 page not found content not the customiser data content and the customiser never loads properly.

#3 @helen
11 years ago

I guess I thought of it as the customizer loading fine, but I see that the front shows a 404 instead of just a white screen now (I was probably doing something weird earlier).

#4 @jeherve
11 years ago

  • Keywords reporter-feedback removed

I also see a 404 page on the front.

#5 @richardmtl
11 years ago

  • Cc richardmtl added

#6 @designsimply
11 years ago

Confirmed using jeherve's steps. Live previews fail if you've trashed the static front page, but I also noticed that both the front page and the posts page have to be blank to trigger the problem.

Here's the error I see if "A static page" is selected and both the "Front page" and "Posts page" are blank in Settings → Reading:

Failed to load resource: the server responded with a status of 404 (Not Found)

http://f.cl.ly/items/1c0r3j1g2E321T1O2v47/Screen%20Shot%202013-02-12%20at%202.42.23%20PM.png

Tested with WordPress trunk r21780.

If you leave "Front page" blank and select a "Posts page," the front page setting is ignored and the latest posts are displayed on the front end and in the customizer. Could the same behavior happen if both of those settings are blank?

#7 @zoonini
11 years ago

  • Cc zoonini added

#8 @jkudish
11 years ago

  • Cc jkudish added

#10 @nacin
11 years ago

Seems like this is a larger issue than just the customizer.

#11 @nacin
11 years ago

  • Version changed from trunk to 3.4

#12 @c3mdigital
11 years ago

  • Keywords has-patch added; needs-patch removed

Patch on #24171 tested and also fixes this bug.

#13 @SergeyBiryukov
11 years ago

  • Keywords has-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like this is not specific to the customizer. Going to close as a duplicate of #24171.

#14 follow-up: @kwight
10 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I think this was still demonstrating a wider issue with the Customizer that still exists: it can't handle 404s in the preview content.

In trunk (I'm on r28183), go to any page that produces a 404, and select the Customizer from the admin bar. The Customizer sidebar loads, but no content (because of the 404). I would expect it to load the same page I was looking at anyways (the 404 template).

#15 in reply to: ↑ 14 @helen
10 years ago

  • Status changed from reopened to closed

Replying to kwight:

I think this was still demonstrating a wider issue with the Customizer that still exists: it can't handle 404s in the preview content.

I think that should be a new ticket, then. I'm not sure what good loading up the 404 page does, but I would agree that something should happen that doesn't make the user feel like something failed.

#16 @helen
10 years ago

  • Resolution set to duplicate

#17 @kwight
10 years ago

Thanks, added in #27992.

#18 @19671007m
3 years ago

  • Component changed from Customize to Upgrade/Install
  • Focuses ui accessibility css docs administration performance privacy ui-copy coding-standards added
  • Keywords needs-testing needs-design added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

#19 @dlh
3 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #24171.

#20 @dlh
3 years ago

  • Component changed from Upgrade/Install to Customize
  • Focuses ui accessibility css docs administration performance privacy ui-copy coding-standards removed
  • Keywords needs-testing needs-design removed
Note: See TracTickets for help on using tickets.