WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#23471 closed enhancement (invalid)

Abstraction of post format parameters (wp_update_post(), XML-RPC, template tags)

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: General Keywords:
Focuses: Cc:

Description (last modified by johnbillion)

#19570 is introducing a UI for post formats. Correspondingly, various post meta fields will be introduced to store the extended data that's used in some post formats (eg. the URL field for a link or the source field for a quote).

Anything that interacts with the XML-RPC API and wants to support post formats (eg. future versions of the WordPress mobile apps) will therefore need to:

  1. Send the various post format meta fields in its requests, and
  2. Receive the various post format meta fields in responses.

There should be some abstraction available at all levels of saving and fetching posts, don't we have to deal with the post meta fields directly. We should:

  1. Introduce a new parameter to the wp.newPost and wp.editPost XML-RPC methods for specifying the values of the extended post format fields when saving posts,
  2. Introduce a new parameter to the wp.getPost and wp.getPosts XML-RPC methods for returning the values of the extended post format fields when fetching posts,
  3. Introduce a new parameter to wp_update_post() for specifying the values of the extended post format fields when saving posts, and
  4. Introduce template tags for displaying/returning the values of the extended post format fields.

Point number 4 may be being covered somewhere else. I know it's been mentioned in IRC but I couldn't find mention of it on Trac.

The end result of this is that extended post format data is abstracted from its storage method.

Consideration: Which of these fields will be required and which are optional (on a per-post-format basis).

Thoughts? I'm happy to volunteer a first patch (or patches).

Change History (6)

comment:1 @johnbillion2 years ago

  • Description modified (diff)
  • Summary changed from Abstraction of post format parameters (wp_insert_post(), XML-RPC, template tags) to Abstraction of post format parameters (wp_update_post(), XML-RPC, template tags)

comment:2 @markoheijnen2 years ago

  • Component changed from General to XML-RPC

Till now there is nothing to do for this. So this ticket is created to early. Somehow this ticket is also a duplicate of #19570. If that ticket change something like this it should also taken care of XML-RPC

comment:3 @nacin2 years ago

  • Component changed from XML-RPC to General
  • Milestone changed from Awaiting Review to 3.6

A) This is not XML-RPC specific.

B) There is no such thing as creating a ticket too early. #19570 is a behemoth project and, inevitably, discrete tasks (especially those not essential and core to the original project) become new tickets.

comment:4 @johnbillion2 years ago

#23927 completed the template tag implementation for post formats.

comment:5 @ryan2 years ago

  • Milestone changed from 3.6 to Future Release

comment:6 @johnbillion22 months ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

This ticket is no longer valid. As part of #24452, the post format post meta fields are being removed so there is no longer anything to abstract.

Note: See TracTickets for help on using tickets.