WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#23489 closed defect (bug) (duplicate)

obscure bug in home_url

Reported by: adelval Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Try this:

echo home_url('?key=f..1').'<br />';
echo home_url().'/?key=f..1');

The former prints only the home url - the argument is ignored or silently consumed. The latter gives the correct result, and the browser doesn't complain about the resulting address (so I assume it's a valid url?)

The issue arised in a situation where we use a key generated with wp_hash_password, and one of the keys had those two consecutive dots.


Change History (1)

#1 @ocean90
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 3.5.1 deleted

Duplicate of #19032.

Note: See TracTickets for help on using tickets.