WordPress.org

Make WordPress Core

#23504 closed task (blessed) (fixed)

Twenty Thirteen

Reported by: markjaquith Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The Twenty Thirteen team has handed the theme over, and we're ready to land it in core and start smoothing out the rough edges. Open new tickets with a component of "Bundled Theme" to track this, and try to attend the Twenty Thirteen office hours on Tuesdays and Thursdays at 1700 UTC.

Change History (22)

comment:1 markjaquith17 months ago

In 23452:

Introduce the Twenty Thirteen theme.

props matt, joen, obenland, lancewillett. see #23504

comment:2 follow-up: nacin17 months ago

Lack of clearing for the sidebar/footer: http://cl.ly/image/0g1R1F3y0Z3V

comment:3 nacin17 months ago

  • Milestone changed from Awaiting Review to 3.6

comment:4 travisnorthcutt17 months ago

  • Cc travis@… added

@nacin trying to reproduce that. What steps led to that?

comment:5 lachlanj17 months ago

  • Cc lachlan@… added

comment:6 sennza17 months ago

  • Cc bronson@… added

comment:7 jeherve17 months ago

  • Cc jeremy+wp@… added

comment:8 jartes17 months ago

  • Cc jartes added

@travisnorthcutt It happens when the height of the main content is lower than the sidebar:
http://joanartes.com/wp-content/uploads/twentythirteen.png
http://joanartes.com/wp-content/uploads/twentythirteen2.png

comment:9 Frank Klein17 months ago

  • Cc Frank Klein added

Besides the clearing issue, maybe the footer could stick to the bottom of the viewport if the content is shorter?

comment:10 taupecat17 months ago

  • Cc tracy@… added

comment:11 lancewillett17 months ago

Non-clearing footer is by design. This theme is intended to be used without a sidebar; if one is enabled, the footer will be just another "band of color" below the content.

comment:12 follow-ups: markoheijnen17 months ago

It's fine that the theme is not intended to have a sidebar but when there is one it should be dealt better. I guess almost everyone would say it is broken how it is now.

comment:13 WraithKenny17 months ago

Any news on when genericons.com will be made not private? It's mentioned in the css as an info link, but it's unavailable to the public as of yet.

comment:14 in reply to: ↑ 12 lancewillett17 months ago

Replying to markoheijnen:

It's fine that the theme is not intended to have a sidebar but when there is one it should be dealt better. I guess almost everyone would say it is broken how it is now.

I thought so, too ... but after working with it for a week or two I've changed my mind. :) Let's give it some time.

comment:15 DrewAPicture17 months ago

  • Cc xoodrew@… added

comment:16 in reply to: ↑ 2 SergeyBiryukov17 months ago

Replying to nacin:

Lack of clearing for the sidebar/footer: http://cl.ly/image/0g1R1F3y0Z3V

Also reported in #23557.

comment:17 in reply to: ↑ 12 MikeHansenMe17 months ago

Replying to markoheijnen:

It's fine that the theme is not intended to have a sidebar but when there is one it should be dealt better. I guess almost everyone would say it is broken how it is now.

I agree, it was the first thing I noticed in the theme. I think that is the general consensus as well. We can give it time but I think I think it is *broken*

Version 0, edited 17 months ago by MikeHansenMe (next)

comment:18 MikeHansenMe17 months ago

  • Cc mdhansen@… added

comment:19 nacin17 months ago

Note that the vast majority of individuals will have a single widget sidebar configured (if only because that is what core has done for them since 3.0), which will automatically map to the first sidebar.

It's a "footer", it shouldn't be left dangling midway up the page like that. I somewhat understand the design sentiment but it looks broken and everyone will think it is broken and unfinished.

If the goal was for the footer sidebar to be first, then it should be registered first. Sidebar descriptions should make it clear that the footer widget area is primary, while the sidebar is optional, and that Twenty Eleven looks great single-column.

comment:20 lancewillett17 months ago

but it looks broken and everyone will think it is broken and unfinished

That leaves little room for the non-everyone people, doesn't it. :)

comment:21 lancewillett17 months ago

Discussed the sidebar and clearing footer today in office hours. Notes here: http://make.wordpress.org/core/2013/02/21/twenty-thirteen-project-update/

comment:22 aaroncampbell14 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Please open new tickets for anything Twenty Thirteen related.

Note: See TracTickets for help on using tickets.