WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#23526 closed defect (bug) (fixed)

Twenty Thirteen: Expanded menu disappears on small screens

Reported by: johnbillion Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. View the Twenty Thirteen theme (demo site: http://twentythirteendemo.wordpress.com/) using a device with a screen narrower than 643 pixels (such as a mobile phone in portrait orientation). You should be served the narrowest layout of Twenty Thirteen, which includes a dropdown navigation menu in place of the horizontal one.
  2. Open the menu.
  3. Scroll down in order to access one of the menu item's that are off the bottom of the screen.

Observe that the menu abruptly disappears once you scroll past the header image, making it impossible to access menu items further down the menu.

Change History (6)

comment:1 lancewillett14 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.6

comment:2 karmatosed14 months ago

  • Cc karmatosed added

comment:3 karmatosed14 months ago

I tested this using an iPhone on landscape and portrait and whilst it does go below and whilst it appears you can scroll it's very jumpy and doesn't really let you click.

I worked a few things using CSS but it seems due to the jumping we need a JavaScript solution here. I can confirm though it's only an issue in landscape.

comment:4 lancewillett14 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 23533:

Twenty Thirteen: disable fixed navbar on small screens. Props obenland, fixes #23647.

Also closes #23526, #23535, and #23566

comment:5 lancewillett14 months ago

  • Keywords needs-patch removed
  • Milestone 3.6 deleted

comment:6 SergeyBiryukov14 months ago

  • Milestone set to 3.6

If the resolution is "fixed", milestone should stay.

Note: See TracTickets for help on using tickets.