WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#23542 closed defect (bug) (duplicate)

Twenty Thirteen: Make videos in video post formats 724px wide

Reported by: obenland Owned by:
Milestone: Priority: low
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Image and video post formats are supposed to display their image/video content at a width of 724px. All other content (if any) should stay at 604px. Image post formats are doing this already, we have to look at videos though.

Attachments (2)

23542.diff (1.4 KB) - added by Mamaduka 3 years ago.
23542.2.diff (1.3 KB) - added by Mamaduka 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 @Mamaduka3 years ago

Only problem with videos is that we need to change wp_embed_defaults() width value to 724px, so iframe can scale properly.

comment:2 @lancewillett3 years ago

Mamaduka -- we can do it by filtering content_width right?

@Mamaduka3 years ago

comment:3 @Mamaduka3 years ago

Lance we're already doing it on template_redirect, but this only would work on single post view, it isn't working on post archives.

Another option is to filter wp_embed_defaults and hard-code width for video post formats.

23542.diff Filters embed defaults, aslo add CSS styling to center video embeds, same way as we do with images.

comment:4 @Mamaduka3 years ago

  • Keywords has-patch added; needs-patch removed

comment:5 follow-up: @obenland3 years ago

Would this also work for legacy video posts from pre-activation?

Did you run in an instance where it is not called in a post context and where a if ( has_post_format( 'video' ) ) wouldn't suffice?

comment:6 in reply to: ↑ 5 ; follow-up: @Mamaduka3 years ago

Replying to obenland:

Would this also work for legacy video posts from pre-activation?

Did you run in an instance where it is not called in a post context and where a if ( has_post_format( 'video' ) ) wouldn't suffice?

Yes it would work, tested by switching between default themes.

Can give more specific example for "not in post context" case?

comment:7 in reply to: ↑ 6 @obenland3 years ago

Replying to Mamaduka:

Can give more specific example for "not in post context" case?

I don't think we need to check the post object, has_post_format() will do that for us.

@Mamaduka3 years ago

comment:8 @lancewillett3 years ago

Let's wait a bit on this ticket -- we'll be soon dropping in the 3.6 Post Formats "structured-post-formats" support, and it'll mean we can style the video separately from the rest of the post content.

comment:9 @lancewillett3 years ago

  • Priority changed from normal to low

Depends now on #23620.

comment:10 follow-up: @mindctrl2 years ago

Just a note: 'defaults' is misspelled in this patch for 'height'.

comment:11 in reply to: ↑ 10 @lancewillett2 years ago

Replying to mindctrl:

Just a note: 'defaults' is misspelled in this patch for 'height'.

Thanks for the note. Chances are we'll avoid this patch altogether based on #23620.

comment:12 @lancewillett2 years ago

  • Keywords has-patch removed
  • Milestone 3.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23620.

Note: See TracTickets for help on using tickets.