WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 10 months ago

#23547 closed defect (bug) (wontfix)

Twenty Thirteen: Genericons don't work in Opera Mini

Reported by: obenland Owned by:
Milestone: Priority: low
Severity: minor Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Let's find out why Genericons currently don't work in Opera and come up with a solution.

Attachments (2)

23547.png (14.7 KB) - added by ocean90 14 months ago.
IMG_0038.PNG (736.6 KB) - added by obenland 14 months ago.
Screenshot Opera Mini

Download all attachments as: .zip

Change History (10)

comment:1 lancewillett14 months ago

  • Priority changed from normal to low
  • Severity changed from normal to minor

ocean9014 months ago

comment:2 ocean9014 months ago

Just tested Opera on Mac and Windows. Can see the icons on both systems. They are only a bit shifted, see attached screenshot.

comment:3 helen14 months ago

Could this be a cross-domain issue? I know Firefox and some versions of IE enforce origin policy per spec. Was going to report it, but thought I'd see if that was the background issue behind this ticket first. Have had to solve it in the past where I don't have control over headers by base64 encoding font files into a stylesheet.

comment:4 lancewillett14 months ago

  • Keywords reporter-feedback added

@obenland We need more info: screenshots, Opera version number and the OS you're testing on, etc.

comment:5 follow-up: obenland14 months ago

  • Keywords reporter-feedback removed
  • Summary changed from Twenty Thirteen: Genericons don't work in Opera to Twenty Thirteen: Genericons don't work in Opera Mini

I can't reproduce it in desktop Opera, it is reproducible on Opera Mini (v 7.0.5.45389) though. I'm not sure we need to fix that though.

obenland14 months ago

Screenshot Opera Mini

comment:6 in reply to: ↑ 5 lancewillett14 months ago

  • Milestone 3.6 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Replying to obenland:

I can't reproduce it in desktop Opera, it is reproducible on Opera Mini (v 7.0.5.45389) though. I'm not sure we need to fix that though.

I'd say "wontfix" in that case. But something to investigate later, for Genericons in general. I'll loop it back to Joen so he can investigate.

comment:7 crondeau14 months ago

I used genericons on my site http://bluelimemedia.com and can confirm that on the iPhone, the icons don't work on Opera Mini, but Opera also does a poor job with gradients, buttons, borders...

Here's a screenshot of my footer on Safari, Chrome and Opera Mini side by side.
You'll see that the icons don't show, but the button also looks like crap and the border is different, so I'm not sure it's worth loosing much sleep.

http://www.bluelimemedia.com/wo/wp-content/uploads/2013/03/iphone-Safari-Chrome-Opera.png

It looks fine on the Desktop using Opera. There's a slight misalignment, but nothing major.

Thanks for these. They're awesome!

comment:8 razeldazel210 months ago

i have a similar issue. i noticed that the icons do not show at all in IE10 on Win7 and only show Glyphs in FF22 on Win7.

Note: See TracTickets for help on using tickets.