WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 14 months ago

#23554 closed defect (bug) (duplicate)

Change Header Delete Behavior

Reported by: tribuseric Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: Cc:

Description

When clicking the Remove header button, it should remove the header image from the list of images for rotation as well as remove from the currently selected image. Currently you must delete the image from the media library (which may be several hundred or thousand images deep) to remove it from the list.

Change History (4)

comment:1 @scribu2 years ago

  • Keywords ux-feedback added

I disagree. I think a better solution would be to have a separate little "Delete" button which appears over each image in the header rotation section, when you hover over it.

Also, I think the "Remove Header Image" button has a very confusing position, in relation to it's effect. It should be right under the currently selected header image.

comment:2 follow-up: @markoheijnen2 years ago

I agree with scribu that this isn't the solution. I think we should rethink the this screen over again. I don't think with the current UI there is a great place to put a delete button/link. I guess the best place now is a delete link underneath the image.

One other thing I noticed was that Uploaded images are connected to a theme. I'm not sure if this is great behavior too.

comment:3 in reply to: ↑ 2 @tribuseric2 years ago

I'll agree that the best way to handle this is probably with a delete button on or next to the image.

I think the reason it's connected to the theme though is that each theme probably has a different sized header. So the theme would break if you left a wrong sized header and made a theme change to one that used a smaller image.

Replying to markoheijnen:

I agree with scribu that this isn't the solution. I think we should rethink the this screen over again. I don't think with the current UI there is a great place to put a delete button/link. I guess the best place now is a delete link underneath the image.

One other thing I noticed was that Uploaded images are connected to a theme. I'm not sure if this is great behavior too.

comment:4 @ocean9014 months ago

  • Keywords ux-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18569.

Note: See TracTickets for help on using tickets.