WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#2356 closed defect (bug) (duplicate)

Image names using the single quote character cause problems in WordPress 2.0

Reported by: dmetzcher Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords: image upload quote bug
Focuses: Cc:

Description

I submitted this to the WP support forum as well: http://wordpress.org/support/topic/58689

I uploaded an image with the following name "Running 'sudo periodic daily' in the Terminal" (notice the two single quotes used in the name). When I uploaded the image, I was unable to use the image upload interface to add the image to my post. I would click the image, and nothing would happen. I verified that this issue was present in Firefox 1.5 and Safari 2, both on Mac OS X. I also verified that other posts with images worked just fine, until I clicked Browse All, and then none of the images, on any posts, would display the popup menu asking me what I wanted to do with it. This was not just affecting the image with the name containing the single quotes, it was affecting all images displayed along with that image in the upload window. If that image was not present in the list, the other images worked fine.

I corrected this by going into the wp-posts table in the WordPress database and looking for the post (post_status=attachement) that contained the information for my image. I edited the record in question, taking out the single quotes in the name, and everything was back to normal.

Not sure what caused this, but it should be pretty easy to reproduce.

Change History (1)

comment:1 skeltoac8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Already fixed. Thank you for reporting.

Note: See TracTickets for help on using tickets.