WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 13 months ago

Last modified 11 months ago

#23564 closed enhancement (duplicate)

Edit Image Should NOT Open New Browser Tab, Improve Workflow

Reported by: webtrainingwheels Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

When clicking Edit Image, opening the image editor in a new browser tab is unexpected behaviour, especially for newbies and even regular users. It often goes unnoticed by them that they have moved to a new tab. So after editing the image, they are at a loss for the next step, how to get back to their post. The fact that they have to go back to another browser tab AND click Refresh is too many steps and non-intuitive. Edit image should happen within the same media window - no new browser tabs.

Change History (4)

comment:1 SergeyBiryukov14 months ago

  • Version changed from 3.5.1 to 3.5

Related: [22755] (for #22083).

comment:2 toscho14 months ago

  • Cc info@… added

comment:3 markoheijnen13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21811.

comment:4 SergeyBiryukov11 months ago

#24573 was marked as a duplicate.

Note: See TracTickets for help on using tickets.