WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 2 weeks ago

#23566 closed defect (bug) (wontfix)

Twenty Thirteen: responsive menu non-functional on Android phones

Reported by: tady Owned by:
Milestone: Priority: low
Severity: major Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The Twenty Thirteen theme proposes a responsive solution. This works great on browser screen resize and iPhone.

The fixed header that appears after scrolling past the main nav, does not appear on Android HTC Desire S. As this is required for responsive use of the site, this is a pretty large failing of the theme. Android older than version 4, does not support the css style "position:fixed".

Tested on HTC Desire S (Android 2.3.5) and Google Nexus 7 (Android 4.2.2), iPad 3 (iOS 6.1.1) and iPhone 4s (iOS 6.1.1).

Change History (14)

comment:1 tady14 months ago

  • Version changed from trunk to 3.5

Also wish to add that the YouTube example does not resize on same Android phone. I realise that developers will create their own themes that may accommodate these features better, but the bundled theme should at least work for all users.

comment:2 SergeyBiryukov14 months ago

  • Version changed from 3.5 to trunk

comment:3 lancewillett14 months ago

  • Milestone changed from Awaiting Review to 3.6
  • Priority changed from normal to low

The theme designer uses an Android ... hmm. :)

Thanks for the reports.

comment:4 mindctrl14 months ago

Samsung Galaxy S3 using Jelly Bean 4.1.1:

Stock browser: menu works fine. The fixed header that appears on scroll looks a bit funky though. The search icon floats left into the site title. Before scrolling and getting the fixed header, the search icon also floats left next to the menu toggle.

Chrome for Android: menu works fine. Fixed header looks rights until you tap the search icon, then it shifts into site title, but this has already been reported elsewhere.

On any mobile view, it would be nice if the menu toggle would appear in the fixed header when scrolling, making nav accessible at any scroll position. But certainly not necessary and not a bug.

Last edited 14 months ago by mindctrl (previous) (diff)

comment:5 lancewillett14 months ago

  • Summary changed from Twenty Thirteen responsive menu non-functional on Android phones to Twenty Thirteen: responsive menu non-functional on Android phones

comment:6 follow-up: lancewillett14 months ago

  • Milestone 3.6 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

In [23533] Twenty Thirteen: disable fixed navbar on small screens. Props obenland, fixes #23647.

Also closes #23526, #23535, and #23566

comment:7 in reply to: ↑ 6 ; follow-up: pkerchner3 weeks ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to lancewillett:

In [23533] Twenty Thirteen: disable fixed navbar on small screens. Props obenland, fixes #23647.

Also closes #23526, #23535, and #23566

hello

is this solution meant to be understood by all wordpress users ?

why does the mobile menu not just work ?

I still have the problem that Twenty Thirteen still has no responsive menu on Android

tiny menu items

comment:8 SergeyBiryukov3 weeks ago

  • Milestone set to Awaiting Review

comment:9 in reply to: ↑ 7 lancewillett3 weeks ago

  • Keywords reporter-feedback added; ui-feedback ux-feedback removed

Replying to pkerchner:

I still have the problem that Twenty Thirteen still has no responsive menu on Android
tiny menu items

In order to help us investigate, could you please add more information? Device type, OS, URL where you see the issue, theme version, WP version, active plugins, steps to repeat it exactly.

comment:10 follow-up: pkerchner3 weeks ago

please have look (with Android) on

http://digitalzumfestpreis.wordpress.com/

it is using

Twenty Thirteen

I am testing with android 4.1.2

see 2 screen copies from mobile device

http://digitalzumfestpreis.wordpress.com/?attachment_id=226

http://digitalzumfestpreis.wordpress.com/?attachment_id=225

comment:11 in reply to: ↑ 10 lancewillett3 weeks ago

  • Keywords close added; reporter-feedback removed

Replying to pkerchner:

please have look (with Android) on
http://digitalzumfestpreis.wordpress.com/

That blog is using a "mobile theme" for mobile views, not Twenty Thirteen's mobile styles.

comment:12 pkerchner3 weeks ago

I think I see what you mean

I used wordpress mobile

not Twenty Thirteen mobile

but there seems to be no auto-responsiveness or Twenty Thirteen mobile features

Twenty Thirteen claims to be responsive

I have to do it all be manual new CSS rules ?

comment:13 lancewillett2 weeks ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

Testing http://digitalzumfestpreis.wordpress.com/ on Android device it looks to be responsive as expected. If you have Custom CSS applied, like for the header image, that isn't accounted for in the default theme styles.

If you need more help, please post on the WordPress.com support forums: http://en.forums.wordpress.com/forum/css-customization

comment:14 lancewillett2 weeks ago

  • Resolution set to wontfix
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.