WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 3 weeks ago

#23575 closed feature request (duplicate)

Standard UI Classes and Functions

Reported by: jscampbell.05 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Administration Keywords:
Focuses: ui Cc:

Description

It would be nice if wordpress allowed you to use the Post UI natively in my plugins, at the moment I've had to write a few classes for my Plugin Framework that mimic the Publish Metabox and Tabbed Metabox.

As there is simply no easy way to do this at the moment, I think there should also be a better way of registering hidden menus. I have to jump through loads of hoops just to do this.

Change History (2)

comment:1 @SergeyBiryukov2 years ago

  • Component changed from General to Administration
  • Keywords ui-focus added
  • Version changed from trunk to 3.5

Sounds like a duplicate of #13375 and #18850.

comment:2 @chriscct73 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13375 and #18850.

Note: See TracTickets for help on using tickets.