WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 8 months ago

Last modified 8 months ago

#23577 closed enhancement (wontfix)

Better Date Fields

Reported by: jscampbell.05 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Administration Keywords:
Focuses: Cc:

Description

I think the Dates should be prettified (i.e 2 days ago etc) and the last state put in front i.e ("Published 2 days ago" rather than "2 days ago Published")

As I think it would make it even more user friendly to used.

I have attached a Image showing what I mean.

Attachments (1)

Screen Shot 2013-02-21 at 11.46.41.png (25.4 KB) - added by jscampbell.05 14 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 jscampbell.0514 months ago

  • Type changed from defect (bug) to enhancement

comment:2 johnbillion14 months ago

#18641 has a patch for the order of the status and the date.

comment:3 SergeyBiryukov14 months ago

  • Component changed from General to Administration
  • Keywords dev-feedback removed

Currently, human-readable format is used for intervals up to 1 day:
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-admin/includes/class-wp-posts-list-table.php#L583

Are you suggesting to display all dates in that format? I prefer to see the actual dates, so I'd call this plugin territory (post_date_column_time filter can be used to change the format).

and the last state put in front i.e ("Published 2 days ago" rather than "2 days ago Published")

That part is a duplicate of #18641.

comment:4 jscampbell.0514 months ago

Couldn't their be an option to set this ? Perhaps in the Screen Options ? Like a Dropdown that has the maximum Threshold.

comment:5 helen14 months ago

  • Keywords close added; ui-feedback ux-feedback removed

Seems to me that the filter is the option. Choosing the threshold for relative time doesn't seem to be a common enough need to warrant an option in the UI.

Again, you'll want to focus on one thing per ticket, and please search for existing tickets first.

comment:6 c3mdigital8 months ago

  • Keywords close removed
  • Resolution set to wontfix
  • Status changed from new to closed

See comment:5

comment:7 SergeyBiryukov8 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.