WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#23598 closed defect (bug) (duplicate)

Retrieving images from the gallery (image.php)

Reported by: sgr33n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords:
Focuses: Cc:

Description

Hi people,

I'm just creating my new wordpress theme and looking at the code of the twenty twelve theme for image.php I see that retrievering images from the gallery doesn't work so good.

Infact looking for the next image it looks at the images attached to the post, not to the ids attribute in the shortcode. For example, if I add a gallery to the post with this code:

[gallery ids="946,945,943"]

image.php will look to all attached images in order to display next and prev images, not to the shortcode attribute.

Change History (2)

comment:1 @SergeyBiryukov2 years ago

  • Component changed from Themes to Gallery
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Retrievering images from the gallery (image.php) to Retrieving images from the gallery (image.php)

Duplicate of #22829 and #22960.

comment:2 @sgr33n2 years ago

Thanks :)
You're better than a search engine about submitted tracs :P

Note: See TracTickets for help on using tickets.