WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#23604 closed defect (bug) (duplicate)

Permalink problem in categories with subcategories

Reported by: dezh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Canonical Keywords:
Focuses: Cc:

Description

Hello,

It think I may have found a bug. Now here's what I noticed:

I use a clean wordpress install (latest version 3.5.1 without plugins or
themes) with permalinks activated (post name).

In any category without child categories, when I type
"www.mysite.com/?cat=2" in the browser, I automatically get redirected to
the category's permalink: "www.mysite.com/categoryname/"

The behavior is different in categories with child categories: automatic
redirection to permalink is not working. I type "www.mysite.com/?cat=3" and
I do not automatically get redirected to the correct permalink. (I stay on
"www.mysite.com/?cat=3".

There's how to provoke the bug:

  • Install the latest wordpress version 3.5.1
  • Create a category with sub-categories
  • Create another category without sub-categories
  • Activate permalinks setting using option "Post name" in Settings > Permalinks
  • type http://www.mysite.com/?cat=ID - replace ID with either a category without

children or with children

Change History (1)

comment:1 @SergeyBiryukov3 years ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15256.

Note: See TracTickets for help on using tickets.