WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#23612 closed defect (bug) (invalid)

Facebook index contains [caption] HTML tag

Reported by: conualfy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

I could recently see one of my shares of a wordpress post on Facebook. It looks like this:

EXCLUSIVE

Interview With Elon Musk on How Model S Manages Cold Weather
www.greenoptimistic.com
[caption id=attachment_33939 align=alignleft width=300] image (c) MotorTrend[/caption] Now that the New York Times scandal is over, I decided to interview Elon Musk about some technical...

I think that you should know this, and if possible, contact Facebook to correct their parser.

Change History (2)

comment:1 @SergeyBiryukov2 years ago

  • Component changed from Post Formats to General
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The shortcode is present in your meta tags:

<meta property="og:description" content="[caption id=attachment_33939 align=alignleft width=300] image (c) MotorTrend[/caption]Now that the New York Times scandal is over, I interviewed Elon Musk about some technical facts on..." />

Since Open Graph meta tags are generated by a plugin, this should be reported to the plugin authors. Please try the support forums: http://wordpress.org/support/

comment:2 @conualfy2 years ago

Sorry, I was in a hurry and did not check it too much. The cause is something that generates the ogg:description in a wrong way (unfiltred):

<meta
property="og:description" content="[caption id=attachment_33939 align=alignleft width=300] image (c) MotorTrend[/caption]Now that the New York Times scandal is over, I interviewed Elon Musk about some technical facts on..." />

Will close the bug myself if possible.

Note: See TracTickets for help on using tickets.