WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#23624 closed defect (bug) (invalid)

oEmbed for Instagram does not terminate the alt attribute

Reported by: lennil Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Embeds Keywords:
Focuses: Cc:

Description

If the url "http://instagram.com/p/WKNIaiArhj/" is put in the content of a post it will produce the following html segment:

<a href="http://instagram.com/p/WKNIaiArhj/"><img src="http://distilleryimage11.instagram.com/4a9a6e6e7f6211e2984f22000a1fb895_7.jpg" alt="Dreamy (photo by Dan Wagener)<a href="http://twitter.com/bmw">#bmw</a>#stancenation" width="612" height="612" /></a>

Change History (5)

#1 follow-up: @kovshenin
9 years ago

  • Cc kovshenin added
  • Keywords reporter-feedback added

I can't reproduce this, the title returned by the Instagram oEmbed endpoint does not contain any links. It looks like you have a plugin which is trying to convert hashtags to links. Can you try to disable all plugins, activate the default WordPress theme and try to reproduce this again? Thanks!

#2 @ocean90
9 years ago

  • Keywords close added; needs-patch removed
  • Severity changed from major to normal

#3 @SergeyBiryukov
9 years ago

  • Component changed from General to Embeds

#4 in reply to: ↑ 1 @johnbillion
9 years ago

  • Keywords reporter-feedback close removed
  • Resolution set to invalid
  • Status changed from new to closed

Replying to kovshenin:

It looks like you have a plugin which is trying to convert hashtags to links.

This is clearly the case. The hashtag is being converted to a link to twitter.com.

#5 @SergeyBiryukov
9 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.