WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#23628 closed defect (bug) (duplicate)

get_post_thumbnail_id() ERROR Fatal Upload image/media fail

Reported by: justintwinpeaks@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: Media Keywords:
Focuses: Cc:

Description

Hi I"ve been looking how to fix this. Fairly new to wordpress platform. I'm not sure how to get into the code to fix this either.

Fatal error: Call to undefined function get_post_thumbnail_id() in /home/xyzxyz/public_html/wp-admin/includes/media.php on line 1173

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version changed from 3.5.1 to 2.9

Related: [12134]

The error message indicates that you have version 3.3.x installed, not 3.5.1:
http://core.trac.wordpress.org/browser/tags/3.3.2/wp-admin/includes/media.php#L1173

In subsequent releases, line numbers where get_post_thumbnail_id() is called are different:
http://core.trac.wordpress.org/browser/tags/3.4.2/wp-admin/includes/media.php#L1181
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-admin/includes/media.php#L1202

This is a duplicate of #12745 and #19814. The issue is a combination of an old release and a theme which calls add_theme_support( 'post-thumbnails' ) too late.

This was fixed in #20556.

Note: See TracTickets for help on using tickets.