Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#23633 closed defect (bug) (duplicate)

Password Protection resets password

Reported by: pamel's profile pamel Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

I think I have found a bug in the password protection of wordpress sites.
I have a page that's visibility is password protected. Now when I update this page I need the passwort to look at it. For this I click at edit and copy the password from the textbox. I dont want to change the password, so I press cancel. The problem is, that when I do this, afterwards, the textbox for the password is empty and so the visibility of the page is public.

Change History (6)

#1 @volcanicpixels
11 years ago

I can reproduce this.

#2 @SergeyBiryukov
11 years ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Password Protection resetes password to Password Protection resets password
  • Version changed from 3.5.1 to 2.7

Duplicate of #23065.

#3 @pamel
11 years ago

  • Keywords needs-patch added
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version 2.7 deleted

I have the Version 3.5.1 of the WordPress core and the patch you have linked is already inside of the code. I've checked the lines of the patch and they are exactly the lines of my code (only the number of the line is a bit different).
The problem is still there even though there is a patch.

#4 @pamel
11 years ago

  • Version set to 3.5.1

#5 @helen
11 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

It's still a duplicate of #23065, which was committed to 3.6, not 3.5.1.

#6 @SergeyBiryukov
11 years ago

  • Version changed from 3.5.1 to 2.7

Version number indicates the earliest affected version, which is 2.7 ([9639] is the relevant changeset).

Note: See TracTickets for help on using tickets.