WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#23663 closed defect (bug) (fixed)

Twenty Thirteen: Redundant esc_url() calls

Reported by: SergeyBiryukov Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Spotted this in custom-header.php: esc_url( header_image() ).

It doesn't work as intended, since header_image() echoes the value directly:
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-includes/theme.php#L983

Attachments (1)

23663.patch (1.1 KB) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (4)

#1 @SergeyBiryukov
7 years ago

I guess we should add esc_url() to header_image() itself, created #23664 for that.

#2 @lancewillett
7 years ago

+1 to add it in header_image itself.

#3 @lancewillett
7 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 23642:

Twenty Thirteen: remove redundant esc_url() calls, props SergeyBiryukov, fixes #23663.

Note: See TracTickets for help on using tickets.