WordPress.org

Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#23676 closed defect (bug) (invalid)

warning 'Invalid argument supplied for foreach()' at /wp-admin/includes/class-wp-list-table.php 344:

Reported by: Scott S Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Plugins Keywords:
Focuses: Cc:

Description

The problem only appears on the "Must Use" and "Drop ins" tables in the plugins page, does not effect normal plugins view, and doesn't seem to affect mu/drop-in functionality

Only happens on 3.5.1

Tried on 6 different 3.5.1 installs, all show the same error

Debug trace results:

Backtrace from warning 'Invalid argument supplied for foreach()' at /opt/lampp/htdocs/themedev/wp-admin/includes/class-wp-list-table.php 344:

1. /opt/lampp/htdocs/themedev/wp-admin/includes/class-wp-plugins-list-table.php 400 calling row_actions()
2. /opt/lampp/htdocs/themedev/wp-admin/includes/class-wp-plugins-list-table.php 296 calling single_row()
3. /opt/lampp/htdocs/themedev/wp-admin/includes/class-wp-list-table.php 796 calling display_rows()
4. /opt/lampp/htdocs/themedev/wp-admin/includes/class-wp-list-table.php 736 calling display_rows_or_placeholder()
5. /opt/lampp/htdocs/themedev/wp-admin/plugins.php 431 calling display()

Attachments (1)

download.png (83.1 KB) - added by Scott S 14 months ago.

Download all attachments as: .zip

Change History (4)

Scott S14 months ago

comment:1 SergeyBiryukov14 months ago

  • Keywords reporter-feedback added

Could not reproduce on a clean install neither in 3.5.1 nor in 3.6-alpha.

Do you have a plugin that hooks into plugin_action_links filter? Looks like the only way to get this warning is to hook into that filter and return something other than an array:
http://core.trac.wordpress.org/browser/tags/3.5.1/wp-admin/includes/class-wp-plugins-list-table.php#L364

comment:2 Scott S14 months ago

  • Keywords close added
  • Resolution set to fixed
  • Status changed from new to closed

Ah yes, it would seem my co-admin updated some plug-ins shortly after I updated the WP install - the issue is being caused by http://wordpress.org/extend/plugins/wp-editor/ this plugin. I'll notify the author.

That'll teach me to check the logs prior to reporting a bug!

comment:3 SergeyBiryukov14 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to invalid
Note: See TracTickets for help on using tickets.