WordPress.org

Make WordPress Core

#23703 closed defect (bug) (fixed)

Posting on WordPress.org support forums defaults to wrong version number occasionally

Reported by: Daedalon Owned by:
Milestone: WordPress.org Priority: normal
Severity: minor Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

When posting to WordPress.org support forums there's a Version field to "Select the version of WordPress you are using".

When the support forum is empty, the value of this field defaults to the latest version of WordPress. I believe this is the optimal choice.

However, when there are posts in the support forum, the value of the Version field defaults to the value used in the last support thread that is shown on the same page.

Example from a moment ago:

  1. On http://wordpress.org/support/plugin/events-manager the form to post a new support thread defaulted to version 3.5.1. The last support thread that was shown on the page was http://wordpress.org/support/topic/page-not-found-for-multiple-events-1?replies=6, about version 3.5.1.
  1. I created a new support thread, which pushed all the other support threads lower on the page and hid the thread that was previously shown as the last one.
  1. The form on http://wordpress.org/support/plugin/events-manager now defaulted to version 3.4.2. The last support thread on the page was http://wordpress.org/support/topic/disable-scroll-zoom-on-google-maps?replies=4, about version 3.4.2.

The form should always default to the latest WordPress version regardless of the versions the previous support tickets are about.

Change History (2)

comment:1 SergeyBiryukov14 months ago

  • Milestone changed from Awaiting Review to WordPress.org

comment:2 coffee2code13 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed and fixed.

For clarification, the WP version dropdown is not given a default value when a forum is empty. With this fix, the WP version dropdown is now also not given a default when topics are present.

Contrary to what the OP suggested in the ticket, the form should not default to the latest version of WP. As it does now, it should not default to any version. We can't assume what version a user is using, and we don't want to mistakenly think it is the latest just because they never verified the default value. Better to have no value than to not trust a value that may or may not be the intent of the user. If a version is present, then you know the user set it.

Note: See TracTickets for help on using tickets.