WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#23747 closed feature request (duplicate)

Ordering Categories

Reported by: valllabh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: 2nd-opinion needs-patch
Focuses: Cc:

Description

There should be provision to order categories. This will open up many possibilities to use with CustomPost types.

Change History (8)

#1 @SergeyBiryukov
7 years ago

  • Severity changed from major to normal

You mean something like My Category Order? Sounds like plugin territory to me.

#2 @valllabh
7 years ago

"My Category Order" is altering the "terms" table and it provides separate UI to order them.

If we are able to define custom Taxonomy, why taxonomy should not have order field. Even posts have order field. This is really very useful.

#4 @wonderboymusic
7 years ago

  • Keywords needs-patch added

#5 follow-up: @husobj
6 years ago

I also think that terms should have a 'menu_order' field in the database and a simple numeric order field (like posts) when editing a term in the admin.

Plugins can provide advanced drag-n-drop ordering functionality but it would make sense for there to be a consistent data field that can be used by all.

I imagine this may be easier to implement once terms are no longer shared as per the [potential roadmap for taxonomies](https://make.wordpress.org/core/2013/07/28/potential-roadmap-for-taxonomy-meta-and-post-relationships/) as terms used by two multiple taxonomies would need to be able to have different order values.

#6 in reply to: ↑ 5 @boonebgorges
6 years ago

  • Milestone changed from Awaiting Review to Future Release

Replying to husobj:

I also think that terms should have a 'menu_order' field in the database and a simple numeric order field (like posts) when editing a term in the admin.

Plugins can provide advanced drag-n-drop ordering functionality but it would make sense for there to be a consistent data field that can be used by all.

I imagine this may be easier to implement once terms are no longer shared as per the [potential roadmap for taxonomies](https://make.wordpress.org/core/2013/07/28/potential-roadmap-for-taxonomy-meta-and-post-relationships/) as terms used by two multiple taxonomies would need to be able to have different order values.

I pretty much agree with this. See https://core.trac.wordpress.org/ticket/30244#comment:2.

#7 @swissspidy
5 years ago

  • Keywords needs-ui removed

I currently use and recommend WP Term Order for this. Term meta is now in core, so this could be leveraged if no other route seems doable.

#8 @SergeyBiryukov
5 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9547 and #30244.

Note: See TracTickets for help on using tickets.