WordPress.org

Make WordPress Core

#23762 closed defect (bug) (fixed)

Twenty Thirteen: max-width stops gallery thumbnails from collapsing on mobile

Reported by: kwight Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

[23675] introduced max-widths for gallery thumbnails, which stop galleries from collapsing to two columns on mobile.

Attachments (5)

23762.diff (392 bytes) - added by kwight 13 months ago.
gallery-column-7-mobile.png (48.2 KB) - added by kwight 13 months ago.
gallery-column-7-mobile-23762diff.png (209.5 KB) - added by kwight 13 months ago.
themebusters-mobile.png (177.6 KB) - added by kwight 13 months ago.
23762.2.diff (1.5 KB) - added by kwight 13 months ago.

Download all attachments as: .zip

Change History (17)

kwight13 months ago

comment:1 lancewillett13 months ago

Can you post before and after screenshots?

Is this happening both index and single views?

I'm not able to repeat with the http://twentythirteendemo.wordpress.com/ demo site.

comment:2 kwight13 months ago

The above screenshots are in single view, on revision 23689. I've noticed the wp.com demo site was behind at other times; I assumed it's not kept totally up-to-date?

Last edited 13 months ago by kwight (previous) (diff)

comment:3 lancewillett13 months ago

The WP.com demo is currently synced up to core changeset r23688.

comment:4 lancewillett13 months ago

@kwight Here's another place to test: http://themebuster.wordpress.net/post-format-test-gallery/2/ -- which is using the gallery test from the Theme Unit Test.

kwight13 months ago

comment:5 kwight13 months ago

The same problem exists forme on the themebusters site.

Am I missing something? Isn't it expected behaviour that galleries with more than two columns collapse to two columns on mobile?..

comment:6 lancewillett13 months ago

  • Milestone changed from Awaiting Review to 3.6

@obenland Let's discuss in office hours: should galleries collapse to 1-2 columns in small screens? Or just respect user column settings.

comment:7 lancewillett13 months ago

Discussed in office hours. Yes, we'd like to go back to the previous design intent, which was forcing 2-col layout for galleries in smaller screens.

kwight13 months ago

comment:8 kwight13 months ago

23762.2.diff lets every gallery with three or more columns collapse to two columns on mobile.

comment:9 lancewillett13 months ago

@kwight Patch isn't working as expected for me. Using the Theme Unit Test gallery post format test, columns of 4-9 are still in 4-9 columns at small screen sizes.

comment:10 kwight13 months ago

Hm, strange – I've double-checked the patch again and still get expected behaviour, on the same unit test data (full revert, svn upped to r23706, downloaded and applied 23762.2.diff above).

Browser? I've only been using Firefox locally, since Chrome and Safari don't get down to the 360px breakpoint. Haven't checked Windows. I'll keep looking.

comment:11 lancewillett13 months ago

Confirmed working now as expected with 2.diff patch applied; testing in Mobile Safari and Mobile Chrome apps.

comment:12 lancewillett13 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 23759:

Twenty Thirteen: provide max-width override for gallery thumbnails to collapse to two columns in small screens. Props kwight, fixes #23762.

Note: See TracTickets for help on using tickets.