WordPress.org

Make WordPress Core

Opened 13 months ago

Last modified 7 months ago

#23807 closed defect (bug)

PHP Strict Mode : Bulk_Plugin_Upgrader_Skin::before() warning — at Initial Version

Reported by: charlestonsw Owned by:
Milestone: 3.6 Priority: normal
Severity: minor Version: 3.5.1
Component: Warnings/Notices Keywords:
Focuses: Cc:

Description

This is from core WP 3.5.1 on my dev box while installing the Debug Bar plugin. This is not the first plugin to trigger this message while testing. I do have strict mode and full warnings/debug messages enabled throughout WordPress and PHP.

Strict Standards: Declaration of Bulk_Plugin_Upgrader_Skin::before() should be compatible with that of Bulk_Upgrader_Skin::before() in /var/www/html/wp-admin/includes/class-wp-upgrader.php on line 1359 Strict Standards: Declaration of Bulk_Plugin_Upgrader_Skin::after() should be compatible with that of Bulk_Upgrader_Skin::after() in /var/www/html/wp-admin/includes/class-wp-upgrader.php on line 1359 Strict Standards: Declaration of Bulk_Theme_Upgrader_Skin::before() should be compatible with that of Bulk_Upgrader_Skin::before() in /var/www/html/wp-admin/includes/class-wp-upgrader.php on line 1394 Strict Standards: Declaration of Bulk_Theme_Upgrader_Skin::after() should be compatible with that of Bulk_Upgrader_Skin::after() in /var/www/html/wp-admin/includes/class-wp-upgrader.php on line 1394

Change History (1)

charlestonsw13 months ago

I believe this patch addresses the problem.

Note: See TracTickets for help on using tickets.