Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#23835 closed defect (bug) (duplicate)

When trashing Post/Page , Menu Item persists and returns 404

Reported by: scamartist26 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords:
Focuses: Cc:


When trashing a Post/Page, if it is in a Menu, that Menu Item should be deleted as well. Currently If a Post/Page is deleted and has a Menu Item, that Menu Item returns the old permalink resulting in a 404. The Menu Item for the deleted Page then needs must be removed by hand.

Change History (2)

comment:1 @helen3 years ago

  • Keywords needs-patch 2nd-opinion ux-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13822.

comment:2 @SergeyBiryukov3 years ago

  • Component changed from General to Menus
  • Version changed from trunk to 3.0
Note: See TracTickets for help on using tickets.