WordPress.org

Make WordPress Core

#23841 closed defect (bug) (fixed)

Twenty Thirteen: Fixed Navbar not activated in IE10

Reported by: celloexpressions Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords: has-patch needs-testing
Focuses: Cc:

Description

The Twenty Thirteen fixed navbar isn't activated in IE10 on win8 (both desktop and not-metro mode, using mouse/keyboard), or on any earlier versions of IE (simulated). It looks like a JS issue; the css works when manually adding .navbar-fixed to <html>, but scrolling breaks the fixed navbar again. It's probably okay if even IE9 doesn't support this, but 10 definitely should, as child themers are likely to make greater use of the fixed nav than Twenty Thirteen does by default and will expect it to work in all modern (non-mobile) browsers.

Note: this should probably be tested with both mouse/keyboard and touch input as IE10 is touch-oriented and touch scrolling may be handled differently.

Attachments (3)

23841.diff (590 bytes) - added by obenland 15 months ago.
23841.1.diff (593 bytes) - added by obenland 15 months ago.
23841.2.diff (2.2 KB) - added by obenland 15 months ago.

Download all attachments as: .zip

Change History (17)

comment:1 lancewillett16 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.6

Thanks for the report. I can confirm it's not working, with both the WP.com demo at http://twentythirteendemo.wordpress.com/ and a self-hosted test install.

comment:2 samiamnot16 months ago

As noted at http://core.trac.wordpress.org/ticket/23803 , wordpress.com is forced into IE9 rendering mode due to an entry in the Microsoft IE10 Compatibility View List (this can easily be changed manually by the user using the developer tools (F-12). This defect appears in other domains as well, but use care when only testing against wordpress.com install.

Version 0, edited 16 months ago by samiamnot (next)

obenland15 months ago

comment:3 obenland15 months ago

  • Keywords has-patch reporter-feedback needs-testing added; needs-patch removed

Could you test again with the attached patch and let me know how it went?

comment:4 follow-up: celloexpressions15 months ago

  • Keywords reporter-feedback removed

Looks good. I checked in IE10 desktop and "immersive" modes with mouse/keyboard. It wouldn't hurt if someone can check it with touch, but I don't know why the revised method wouldn't work regardless of input method.

It also works for IE10 emulating 9, but not 8, although I don't think this is important enough to support for 8 unless there's a quick fix.

obenland15 months ago

comment:5 in reply to: ↑ 4 ; follow-up: obenland15 months ago

Replying to celloexpressions:

It also works for IE10 emulating 9, but not 8

Yeah, that'sno good. What about the .1 patch, does that work better?

comment:6 in reply to: ↑ 5 celloexpressions15 months ago

Replying to obenland:

Replying to celloexpressions:

It also works for IE10 emulating 9, but not 8

Yeah, that's no good. What about the .1 patch, does that work better?

Unfortunately, that still doesn't work for 8. There may be more bugs with the emulation (like the one mentioned in #23803), but it doesn't work in IE Tester either.

comment:7 follow-up: RDall15 months ago

I did a test with Windows 7 and IE 10 on 3.6-beta1-23930 and couldn't see the fixed navigation either.

See attached screenshot. (Taken from my PC)

http://cl.ly/image/3z2641303z2b

comment:8 in reply to: ↑ 7 lancewillett15 months ago

Replying to RDall:

I did a test with Windows 7 and IE 10 on 3.6-beta1-23930 and couldn't see the fixed navigation either.

Did you try with Obenland's patch applied?

obenland15 months ago

comment:9 obenland15 months ago

New patch works.

comment:10 rdall15 months ago

Sweet… Sorry couldn't help more… Going to attempted SVN install today… Wish me luck. obenland lancewillett

comment:11 follow-up: celloexpressions15 months ago

Unfortunately that still doesn't work on 8 for me, but I don't think we really need to worry about 8 for this. Maybe just the simpler (original) patch that worked for 9/10 is enough, unless you can confirm that this works on 8 or need all of those changes (besides just the one line) for another reason.

comment:12 in reply to: ↑ 11 obenland15 months ago

Weird, it works for me both in IE8 on win7 and IE10 on win8 in IE8 mode. Thanks for looking, though!

comment:13 celloexpressions15 months ago

It must just be something wrong with my setup I guess (win8 with 10 emulating 8). It looks right in the code.

comment:14 lancewillett15 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 23965:

Twenty Thirteen: adjust JavaScript handling for scrolling and finding viewport heigh/width to better support various IE versions. Also consolidate variables at the top of the file per best practices. Fixes #23841, props obenland.

Note: See TracTickets for help on using tickets.