WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #23880, comment 61


Ignore:
Timestamp:
12/14/2015 01:56:32 AM (5 years ago)
Author:
maratbn
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #23880, comment 61

    initial v1  
    33So far I released 2 plugins that require PHP >= 5.4 due to the use of short echo tags and namespaces.
    44
    5 Most of the problems reported by users are from trying to run the plugins on PHP < 5.3, which do not have namespace support.  I already have logic to test for PHP < 5.4, but that only works on PHP 5.3, because anything less will error-out on the namespace syntax, which also has to be the first line.
     5Most of the problems reported by users are from trying to run the plugins on PHP < 5.3, which does not have namespace support.  I already have logic to test for PHP < 5.4, but that only works on PHP 5.3, because anything less will error-out on the namespace syntax, which also has to be the first line.
    66
    77Work-arounds for that would add a slight performance penalty for each HTTP request to the site, which is just not worth it for the vast majority of users running some more recent PHP.  But if WordPress already did this the same way it already checks for compatible WordPress versions when installing themes/plugins there would be no additional performance penalty.