WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#23893 closed defect (bug) (fixed)

Post format should be revisioned, auto-saved and previewable

Reported by: kovshenin Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version:
Component: Post Formats Keywords:
Focuses: Cc:

Description

Like the post format metadata in #23539, the post format itself should be revisioned. Steps to reproduce:

  1. Publish a standard post
  2. Change the format to image, set the content to "this is an image", update
  3. Change the format to quote, set the content to "this is a quote", update
  4. Restore the "this is an image" revision

The post is restored to the "this is an image" post, but the format is still a quote. This could be part of a bigger "revisions for taxonomies" feature.

Attachments (2)

23893.diff (3.8 KB) - added by kovshenin 8 years ago.
23893.2.diff (5.1 KB) - added by kovshenin 7 years ago.

Download all attachments as: .zip

Change History (8)

#1 @kovshenin
8 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

23893.diff is an approach similar to [23859] and [23862].

@kovshenin
8 years ago

#2 @kovshenin
8 years ago

It looks like the change in supports on the revision post type is not needed. I think I left it there because I was using get_post_format on revision posts when debugging.

@kovshenin
7 years ago

#3 @kovshenin
7 years ago

23893.2.diff uses post meta to store revisioned terms for post formats and introduces a more generic approach when handling autosaves. Categories and tags could easily fit into this.

#4 @kovshenin
7 years ago

On second thought, I think doing terms revision is overkill for now and would rather go with storing the format in post meta. A full-blown tax/terms revision framework can go in after #20564 is closed.

#5 @kovshenin
7 years ago

There's a patch for this sitting in #20564.

#6 @kovshenin
7 years ago

  • Keywords has-patch needs-testing removed
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [23928]

Note: See TracTickets for help on using tickets.