WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#23908 closed defect (bug) (invalid)

wp_nav_menu generates wrong classes for li elements

Reported by: anyname2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Menus Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

Function wp_nav_menu generates 2 different classes for <li> with exactly the same meaning: e.g. current-page-parent and current_page_parent. It sometimes generates one of them, but sometimes both.

Also this coresponds to current-page-ancestor and current_page_ancestor classes.

I think there should be one of them, but to preserve compatibility with older websites, it is better to leave both but generate both at the same time, so that user could use either "-" or "_" as separators.

Change History (6)

#1 @Latz
6 years ago

Hello anyname2,

thank you for your report. Sorry you never got a response.

I can't find any appearances of current-page-parent or current-page-ancestor in the code. Could you narrow down where you think the problem is occurring?

This ticket was mentioned in IRC in #wordpress-dev by helen. View the logs.


6 years ago

#3 @wonderboymusic
5 years ago

  • Keywords reporter-feedback added; dev-feedback removed

#4 @Latz
5 years ago

The class current_page_ancestor is added intentionally for backward compatibility with the current_page_ classes defaults (#12812). I think this is a wontfix.

#5 @chriscct7
4 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Per #12812, this is intended behavior.

#6 @chriscct7
4 years ago

  • Resolution changed from worksforme to invalid
Note: See TracTickets for help on using tickets.