WordPress.org

Make WordPress Core

#23911 closed defect (bug) (duplicate)

Post Format UI Bar always displays "Standard Post" instead of correct post format on initial load of post.php

Reported by: c3mdigital Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Post Formats Keywords: has-patch
Focuses: Cc:

Description

When loading an existing post with a selected post format the format in the selector bar UI will always display "Standard Post" until the various formats are hovered over which it will then default back to the correct format after hovering.

This patch checks for the current post format and fills the .post-format-tip span with the correct current post format in post-formats.js

Attachments (2)

23911.patch (447 bytes) - added by c3mdigital 13 months ago.
23911.2.patch (514 bytes) - added by SergeyBiryukov 13 months ago.

Download all attachments as: .zip

Change History (5)

c3mdigital13 months ago

SergeyBiryukov13 months ago

comment:1 SergeyBiryukov13 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 3.6

23911.patch is not localizable.

23911.2.patch copies the actual post format button title.

Noticed some more i18n issues in [23843], added to #23503.

comment:2 johnbillion13 months ago

My patch on #23503 fixes this server-side instead of using JS. Suggest marking as dupe of #23503 which also addresses the associated issues.

comment:3 helen13 months ago

  • Keywords commit removed
  • Milestone 3.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23503.

Agree, was just looking at what exactly the issue is and it should be fixed server-side.

Note: See TracTickets for help on using tickets.