WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#23944 closed enhancement (fixed)

Update to latest jquery.form

Reported by: usermrpapa Owned by: nacin
Milestone: 3.7 Priority: normal
Severity: normal Version: 3.6
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Description

Any chance of getting the included jquery.form update to the latest version? We keep running into various script errors (mostly access) within jquery.form with IE. Updating to the latest jquery.form corrects these errors.

WP using version 2.73 and the latest is 3.32

Thanks for consideration...

Attachments (2)

23944.diff (60.4 KB) - added by JustinSainton 7 years ago.
23944.1.diff (60.9 KB) - added by JustinSainton 7 years ago.
Updating again to latest.

Download all attachments as: .zip

Change History (8)

#1 @nacin
7 years ago

  • Keywords needs-patch added

We don't use it at all. The comment next to it is "deprecated, not used in core, most functionality is included in jQuery 1.3"

So yeah, happy to update it to latest.

@JustinSainton
7 years ago

#2 @JustinSainton
7 years ago

  • Keywords has-patch added; needs-patch removed

#3 @usermrpapa
7 years ago

whoops.. beat me to it! ;)

good deal!

@JustinSainton
7 years ago

Updating again to latest.

#4 @SergeyBiryukov
7 years ago

  • Milestone changed from Awaiting Review to 3.7

#5 @nacin
7 years ago

Latest now appears to be 3.37.0: https://github.com/malsup/form/releases.

#6 @nacin
7 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 25462:

Update jQuery Form to 3.37.0 (unused in WP core).

props usermrpapa.
fixes #23944.

Note: See TracTickets for help on using tickets.