WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#2396 closed defect (bug) (duplicate)

Not found in stead of 404

Reported by: jadr Owned by:
Milestone: Priority: low
Severity: trivial Version: 2.0
Component: General Keywords: 404, search
Focuses: Cc:

Description

When entering errorous URLs the 404 should show, but.. :

Entering:
http://www.boyer-draeby.dk/category/events/2222

  • gives me a "Not found" (search) result

Where as the below returns a true 404:
http://www.boyer-draeby.dk/2222

I've customized the permalinks, perhaps this is to blame ?

Change History (2)

comment:1 @davidhouse10 years ago

If no posts are found then the 404.php template from a theme is used, you don't have to worry about ErrorDocument directives. Is this what you are doing?

comment:2 @markjaquith10 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2123

This was a bug in WordPress 2.0. It was fixed in [3484] which made it into WP 2.0.1

Note: See TracTickets for help on using tickets.