WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#23968 closed defect (bug) (worksforme)

HTTP error during image upload having PHP 5.3

Reported by: utnalove Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5.1
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

According to the requirements PHP 5.3 is supported.

But it looks like it is not. Check here.
My case was here instead.

PROBLEM:
Uploading images using the "media upload" window gives an error almost always. If I highlight the images that were uploaded with the error, the media upload window doesn't show any size for them.

In order to reproduce the error and have guaranteed that it will fail, is to use the /wp-admin/media-new.php?browser-uploader
So it will show the following:

503 Service Unavailable
The server is temporarily busy, try again later!
Powered By LiteSpeed Web Server

It all worked fine for years. Only after my hosting upgraded to PHP 5.3 it broke.

Change History (6)

comment:1 utnalove13 months ago

  • Cc sergioloporto@… added
  • Severity changed from major to critical

comment:2 markoheijnen13 months ago

  • Severity changed from critical to normal

The first link you passed was a hosting issue and there is a big change that your issue is also the cause of your hosting company. I guess you better can use the forum and provide the PHP error log over there.

comment:3 follow-up: SergeyBiryukov13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

"503 Service Unavailable" is definitely a hosting issue. Please continue with your topic on the forums.

Feel free to reopen with more information if the root cause turns out to be a bug in core.

comment:4 in reply to: ↑ 3 utnalove13 months ago

Replying to SergeyBiryukov:

"503 Service Unavailable" is definitely a hosting issue. Please continue with your topic on the forums.

Feel free to reopen with more information if the root cause turns out to be a bug in core.

Thanks for the info. The hosting told me how to change php to 5.4 and 5.2. They both work. But php 5.3 doesn't.

They also addeed this "You would want to contact the developers of your script, it may be that the script simply doesn't work with PHP 5.3. There's a lot of differences between PHP 5.2 and PHP 5.3."

Eh. I'll see if they can investigate. Also the person I hired to check the issue said it's a hosting problem.

comment:5 toscho13 months ago

  • Cc info@… added
  • Keywords needs-patch added

Confirmed with with PHP 5.3.8 on Apache. It does not happen when I use the Upload New Media page.

I will try to get the error log later.

comment:6 SergeyBiryukov13 months ago

  • Keywords reporter-feedback added; needs-patch removed

Could not reproduce with PHP 5.3.3 on Apache neither on Edit Post nor on Upload New Media screen.

Note: See TracTickets for help on using tickets.